Zigbee RaspBee2 adapter cannot find - how to integrate hardware

Hi all,
I´ve mount the RaspBee 2 adapter for Zigbee in my raspberry Pi. During creating a Zigbee network I cannot find where to integrate the Zigbee adapter itself? Could somebody tell me how to integrate the hardware adapter in the raspberry?

Hello,

this should help:
https://nymea.io/documentation/users/usage/configuration#zigbee

Hi mzanetti,
thanks for your quick response :slight_smile:

I wrote that doc already but I didn´t get the information how the adapter of the RaspBee II to be added and configured manually. In the documentation there is shown a screenshot of a selection where you can choose the adapter (I cannot see anything at that point).
How can I add and configurate the adapter?
Where I can proove if the ZigBee2 adapter is connected with the appropriate port?

I tried to write it down more understandable. Hope you can help?
Cheers
Rob

Hey @Rob

I believe your issue may be because of the serial port not properly configured on the Raspberry Pi.

Log in via SSH (username nymea, password nymea if you’re using the official image) and run the following command:

sudo raspi-config

In the menu that appears, open “Interface options” → “Serial Port”. On the question “Would you like a login shell to be accessible over serial?” select No. On the next question “Would you like the serial power hardware to be enabled?” select Yes. Then exit the configuration and reboot the raspberry pi.

Then your RaspBee should appear in the zigbee settings as /dev/ttyS0

Hi mzanetti,

sry for boring questions.
I want to figure out if that is the reason.
But I don´t know how to login via SSH?
When I start the raspberry it shows the nymea view and I cannot see where I can log in to SSH.

Oh ok, I see. Well, in that case it’s probably easier if you put the SD card into your computer and edit config.txt, then add this at the bottom:

[all]
enable_uart=1

This would have the same effect as the above with ssh and raspi-config.

I’ll change the nymea image to have this enabled by default…

Hi
So I add

[all]
enable_uart=1

But I have still that problem.
Now there is one more network to add.
Next try: Attached there are some screenshots which show the situation

/dev/ttyS0 should be the right one… I’ve just tested it here on a RPi and the ConBee II. Once the /dev/ttyS0 appeared and I added the zigbee network on it, it started working.

Doesn’t work with raspbee II

Sorry, I meant the RaspBee II. I’ve tested it with that… hmm… well, then please go to system settings → developer tools → enable the debug interface. Then open it with the browser and go to the logs tab. Enable all debug logs related to ZigBee.

Then remove all your zigbee networks and create one using /dev/ttyS0. When it fails, to back to the web interface and download the syslog to post it here.

My guess is you missed to disable the tty on the new enabled uart interface!
You can check the /boot/cmdline.txt on your SD and change the console:

console=tty1

Maybe that fixes the not working communication.

You can check the official documentation from deCONZ: RaspBee II Installation

Simon is right, mostly.

I’ve just restored the plain image and then added enable_uart=1 to config.txt and while /dev/ttyS0 did show up, it was not able to start the Zigbee network.

After also editing cmdline.txt and removing the following part console=serial0,115200 it started working (the console=tty1 as simon said is already there, and should be left untouched).

I’ve adjusted the nymea image to have those changes already. @Rob if you download the latest experimental image now, it should work without having to modify any configuration files: https://downloads.nymea.io/images/raspberrypi/experimental/nymea-core-image-raspios-bullseye-2022-07-05.zip

Hi Simon, hi mzanetti,
thanks for your help. I changed the following like you said:

  1. “console=tty3” to “console=tty1” in /boot/cmdline.txt
  2. added enable_uart=1 to config.txt
  3. editing cmdline.txt and removing the following part console=serial0,115200

Now I have a connection and I can add my motion sensor (it is added but as a “unknown sensor” :slight_smile: .

in the Dashboard item “Thinks” I can not create / there is no field where I can choose the motion sensor. Could it be that the reason is the “unknown sensor” after adding it in the zigbee network?

What device is it exactly? Could be it’s not supported properly yet.

the device was integrated by Simon. It works in the past until I got the problems with the connection.