Windows app does not find RaspberryPi core

Hi all,
This is my first post, and probably has been asked many times before.
I have the app installed on my Windows PC, and the core is on a RaspberryPi on the same wired network.
The app searches for but doesn’t find the core.
Is there some simple step that I’ve missed?
Thanks

Hi @Westcott1, welcome to nymea.

I had seen this before and I believe it was the windows firewall preventing the application to perform the UPnP discovery. I’m not entirely sure which setting it is but so far it always started working after tweaking some settings there.

If you manage to track it down to a particular setting, please let me know.

Thanks!
I tried ‘Manual connection’ but it gives “An unknown error happened - Error code: 10”
However, that connection is shown as “Oh look! There are…”
“Manual connection”
nymeas://raspberrypi-4b:2223

Does it work with the app on another device (e.g. on the mobile phone)? If so, verify that the port settling is ok please.

Hi Mzanetti,
Yes, the app on my tablet connects immediately
Sorry, but how do I verify that the port settling is OK?
Thanks.

System settings -> API interfaces

There you can check the options you have for the manual connection.

Thanks!
I can’t find that option on Windows, it only shows the “Connect nymea” tab.
On the tablet it shows TCP port 2222, and Websocket port 4444

What I mean is that you can check the app on the tablet what is configured. And then use those values in the manual connection on windows.

Thanks, I had already tried that, with both ports 2222 and 4444.
2222 says “nymea:core has closed the connection. This probably means…”
4444 hangs on “Connecting…”
App still works fine on my tablet.

In app settings -> developer tools you’ll find logging for the app. Enable that please. When you’re trying to connect you’ll see a log icon in the corner. Please paste me that.

nymea:app 1.0.225 running on “Hamish-PC” “Windows 10 (10.0)” “windows” “10”
Locale info: QLocale(English, Default, United Kingdom) “en_GB” QLocale::English QLocale(English, Default, United Kingdom)
Loaded translation for locale QLocale(English, Default, United Kingdom)
Loaded Host from cache “Demo server” QUuid("{6c047fec-78da-46af-990a-8f687216ae1b}")
|- Connection: “0” QUrl(“nymea://nymea.nymea.io:2222”) Connection::BearerTypeWan secure: false
UPnP: Discovering on QHostAddress(“172.16.0.97”) 49125
UPnP: Discovery could not bind to interface QHostAddress(“169.254.66.180”)
UPnP: Discovery could not bind to interface QHostAddress(“169.254.122.145”)
UPnP: Discovery could not bind to interface QHostAddress(“169.254.200.253”)
UPnP: Discovery could not bind to interface QHostAddress(“169.254.105.227”)
UPnP: Discovering on QHostAddress(“127.0.0.1”) 49125
Zeroconf support not compiled in. Zeroconf will not be available.
No current host… Nothing to do…
UPNP: Discovery started…
Setting AWS configuration to “Community”
AWS not logged in. Cannot register for push
Ready to connect
qrc:/ui/RootItem.qml:373:31: QML TabButton: Binding loop detected for property “width”
: QML QQuickLayoutAttached: Binding loop detected for property “preferredHeight”
No current host… Nothing to do…
UPnP: Error fetching discovery data: 404 QNetworkReply::ContentNotFoundError “Error transferring http://172.16.0.147:80/server.xml - server replied: Not Found”
UPnP: Error fetching discovery data: 404 QNetworkReply::ContentNotFoundError “Error transferring http://172.16.0.111:80/server.xml - server replied: Not Found”

Hi

So this does confirm my suspicion that for some reason it can’t do a UPnP discovery. As I said before, this normally is due to some security settings on windows. I’ll need to look into it again what exactly the problem is.

As for the manual connection, I don’t see a connection attempt in those logs. Please try again to do the manual connect and check the logs again.

Hi again,

I’ve tried to reproduce this it does work fine in my Windows VM. However, reading through the code I have discovered a potential issue which might cause troubles for you.
Also, I have verified that the default ports in the Raspberry Pi image are 2222 and 4444 with SSL enabled but the app suggests 2223 and 4445 for the manual connection when SSL is enabled. This is indeed misleading. Thanks for pointing this out, I’ve adjusted that in the app.

Can you please try this build: https://downloads.nymea.io/nymea-app/beta/nymea-app-win-installer-1.0.262.exe

Here’s hoping that it should work for you, and if not, I’ve added a bit more debug info to the log which might help me to track it down further if it’s still not working for you.

Hi Mzanetti,
Although it didn’t find a core automatically, manual setup on port 2222 worked correctly.
All I have to do now is set up some stuff.
I do have a fairly large existing setup, Zigbee, Zwave, 433MHz, Domoticz, and my own Python Python and Node.js apps.
Thanks!

Would you mind testing the latest beta nevertheless and let me know if it fixes the issue with the discovery?

Thanks a lot

Here’s a log of the latest beta in auto-discovery mode -

Received UPnP datagram: “HTTP/1.1 200 OK\r\nST: urn:schemas-upnp-org:service:ConnectionManager:1\r\nUSN: uuid:7d68f60d-65d6-4cf8-81c5-beeeb2191b67::urn:schemas-upnp-org:service:ConnectionManager:1\r\nLocation: http://127.0.0.1:2869/upnphost/udhisapi.dll?content=uuid:7d68f60d-65d6-4cf8-81c5-beeeb2191b67\r\nOPT:“http://schemas.upnp.org/upnp/1/0/”; ns=01\r\n01-NLS: 2c1aac025f77eca10d63580c13aabe5b\r\nCache-Control: max-age=900\r\nServer: Microsoft-Windows/10.0 UPnP/1.0 UPnP-Device-Host/1.0\r\nExt: \r\nDate: Wed, 23 Dec 2020 14:07:24 GMT\r\n\r\n”
Received UPnP datagram: “HTTP/1.1 200 OK\r\nST: urn:schemas-upnp-org:service:ConnectionManager:1\r\nUSN: uuid:7d68f60d-65d6-4cf8-81c5-beeeb2191b67::urn:schemas-upnp-org:service:ConnectionManager:1\r\nLocation: http://127.0.0.1:2869/upnphost/udhisapi.dll?content=uuid:7d68f60d-65d6-4cf8-81c5-beeeb2191b67\r\nOPT:“http://schemas.upnp.org/upnp/1/0/”; ns=01\r\n01-NLS: 2c1aac025f77eca10d63580c13aabe5b\r\nCache-Control: max-age=900\r\nServer: Microsoft-Windows/10.0 UPnP/1.0 UPnP-Device-Host/1.0\r\nExt: \r\nDate: Wed, 23 Dec 2020 14:07:24 GMT\r\n\r\n”

I understand it’s still not managing to discover nymea in the network for you, is that right?

That log snippet only contains some replies from your router. Would be helpful if you’d paste the entire log.

Yes, it’s still not auto discovering.
As a new forum member, I’m limited in what I can paste.
All other log entries look just like the bit I did manage to paste.