Wifi country not set and wpa_supplicant.conf not up to date


#1

Hello,

So first I should say that I am a totally new to raspberry pi, and I don’t know my way around every aspect of linux as well yet, so I apologize in advance if my questions seem irrelevant. Also, I’d like to thank your for BerryLan, which is exactly what I needed (I move a lot, and a simple wireless way to connect raspberry to the current wifi network is a perfect tool for me).

But, i do have some questions. I can’t seem to set my wifi country code setting on a raspberry pi running BerryLan, I have not issue on other raspberry where BerryLan is not configured, and I can set it either using raspi-config, or the network interface icon on Pixel. But on the one Berrylan is installed, setting doesn’t seem to be saved when I use raspi-config and on Pixel the newtwork interface icon indicates that no wireless interface is connected (while I’m using wifi to connect to the raspberry, so it is working).

And that let me to my second question, if i want to manually add a network, I cannot use the new the network icon in pixel (I have a “connexion to dhcpcd lost” tooltip) and It seems the wpa_supplicant file is not the one used to store wifi network access. So is there a way to make the dhcpcd interface work in the or where could I find the file listing the possible wifi connexion ?

Thanks a lot for anybody who might point me in the right direction to understand a little more how I could fixe those little issues.


#2

Hello,

Setting the country code is currently not supported indeed. Thanks for the feedback, it should be added to Berrylan.

The Berrylan image uses NetworkManager instead of dhcpcd to configure the network. If you want to manually configure a network connection there you can use nmcli:

Scanning for wifi networks:
nmcli device wifi rescan
nmcli device wifi list

Connecting to a wifi
nmcli device wifi connect SSID-Name password wireless-password

I hope this helps to get you going. Thanks again for the feedback with the country code!