Webasto Modbus setup

Hi All!

How to setup exactly these requirements?

The plugin is installed. But how to enable the server, and how to set the slave register address and port???

Thank you!


  • The packages ‘nymea-plugin-webasto’ must be installed.
  • The modbus server must be enabled
  • The setting ‘Modbus Slave Register Address Set’ must be set to ‘TQ-DM100’
  • The setting ‘Modbus TCP Server Port Number’ must be set to 502

I think that’s to be set on the webasto wallbox, in the web interface.

Port is ok but the other one is missing.

Hi @apeelme ,

is this a Webasto NEXT or a Webasto Live?

If this is a Webasto Live your settings should be fine and the current stable should work for you.

Since I see there the HEMS activated I assume this is the Webasto NEXT. If that is the case, the wallbox is not fully supported yet, but there is a test branch ready to be used in the experimental repository. Also the documentation has been updated a bit regarding the requirements.

Please not that there is at the moment still an issue left with the NEXT integration we are currently debugging together with Webasto. But I think it will soon be ready to be used.

1 Like

Thanks Simon! Good to hear! Yes, this is a NEXT.
I will try this repo. :wink:

The bug in the Webstao NEXT integration code has been fixed and it will probably be released in the next release. Then you should have full support of the wallbox :slight_smile:

The fix is already in experimental if you want to test it.

1 Like

That’s great! Thank you! :wink: