UniPi plugin won't install

New member/new user of Nymea and I have some issues. Brand new RPi 4 plugged into a UniPi 1.1(not Lite) and running Bullseye. System boots up fine and loads Nymea. WiFi connects in and everything seems to be fine. I have added the onewire plug-in and modified the config.txt with dtparam=i2c_arm=on and dtoverlay=pwm-2chan as mentioned in other posts. I tried to install the UniPi plug-in and it thinks about it for awhile and the returns to the plug-in screen with the Installed version: Not installed
I tried installing it manually and it reports a message that the package “wiringpi” is not installed.

I’m at a loss at this point on how to proceed. Any suggestions would be most helpful!


Thanks for reporting the issue. I can reproduce the error. The wiringpi package got deprecated and removed from Bullseye. This dependency will be removed.

Thanks for confirming the problem. I realize that the UniPi 1.1 is probably not the most recent piece of hardware, so it’s not easy to test everything.

Do you have a patch or some instructions on how I can continue to move forward with my installation?

The PR for the patch is created, it takes now some days until the new version is available. If you are familiar with Software compiling you could compile the plug-in on your Pi using the following comands:

git clone https://github.com/nymea/nymea-plugins-modbus.git
cd nymea-plugins-modbus/unipi
mkdir build && cd build
qmake ..
sudo make install
sudo systemctl restart nymead

You will need to install all the tools and libraries needed to compile it. I recommend to wait until the package is available (usually take a couple of days).

Thanks. I’m familiar with Linux, but certainly not a guru. I’ll wait for the patch.

I’ve been away from this project for awhile, so I haven’t been following this too closely. Did a patch ever get pushed out for this issue?