Support for Hue wall switch in zigbeephilipshue plugin


Support for the Hue wall switch was recently added to the philipshue plugin.
As I want to run my Nymea setup without a Hue bridge I was wondering if the same could be done for the zigbeephilipshue plugin.

Hi, yes that should be possible. However, the person who contributed that patch to the hue plugin doesn’t have a zigbee dongle, and the ones who have zigbee dongles don’t have that device :slight_smile:

So, one thing you could help with, would be to provide us the logs of nymea when you add this device to the zigbee network. That should give us all the information required to add support for it (assuming it’s somewhat ZigBee spec compliant).

For that, please enable the debug interface in system settings → developer tools. Then open the debug interface and move to the Logs tab. Enable the “Zigbee”, “ZigbeeNetwork” and “ZigbeeResource” logs, as well as the “ZigbeePhilipsHue” and perhaps also “ZigbeeGeneric” plugin logs below.

Then make sure to remove the node from the zigbee network, open the network for new devices to join and connect it again. That should print everything we need. Check out the logs column here to examples of what logs we’re after: Zigbee device support status - Google Sheets

Here’s the log output: I | Zigbee: Set permit joining in network ZigbeeNetwork(00:21:2E:FF:FF:06:4B:84 -

That looks good, thanks. Will look into it asap.

Hey again. I’ve looked at it now and to be honest I’m a bit surprised it wouldn’t work. Do you have nymea-plugin-zigbee-philipshue installed? It really should be picked up then, albeit being wrongly identified as a Hue Smart button.

Yes, the plugin is installed. Version 0.29.1+202110041537~buster+rpi1.
I have some Hue lamps which work fine using that plugin.

And maybe to be more explicit about what I’m seeing:

  • The Zigbee node is discovered and added to the Zigbee nodes in the Nymea UI
  • When I press the button connected to the Hue wall switch, the gray circle of the Zigbee node in the Nymea UI becomes green
  • No “Thing” is added to my Things in Nymea

Ok, looked into it again. I still can’t see a difference between the wall switch module and the Hue Smart Button in terms of what they announce on the ZigBee layer. However, obviously there must be a difference and I just didn’t find it yet.
I’ve created some patches now (to the zigbee stack and the zigbee-hue plugin) to print some more details about the device, hopefully that gives me a clue.

So I’d need you to upgrade your setup to experimental (system settings → sytem updates → configure → enable experimental) and repeat the above test please.

Here’s the new log: I | ZigbeeNetwork: Received unhandled broadcast ZDO indication APSDE-DATA.indic -

Switch now shows up as a Thing in the UI, but pressing the button connected to the wall switch module does not work. Gray circle of the Zigbee node does not turn green anymore.

OK, try now please. Should work now. Although I’m not 100% sure if I’ve mapped the buttons properly. How many buttons would this device support? And what about longpress, double-press etc?

Please remove it from the network and add it again, then press all the possible combinations on the switch and send me the logs again, ideally with a description of what you’ve pressed along with a given log snippet.

OK; I updated an removed/added the device.

The device supports 2 buttons; I’ve tried both, short, long, but nothing shows up in the logs. Are there other log filters that I need to enable?

I found this deconz related pull request with information about the device; maybe that helps?

Can’t seem to post to link to the logs on pastebin

Discourse seems to have identified your posts as spam because of all the links. Should work again now.

So none of the buttons are working for you is what you’re saying?

Indeed, none of the buttons are working.

Can you try Posting the logs again? If the buttons are not printing anything, the logs from the setup would be helpful

It’s still not letting me post links.
Pastebin url ending in fM5sFwWU

Thanks for the logs. I might have made a mistake there… Next build is running. Thanks for your patience.

Thanx for all your help so far. Let me know when you need me to test again.

Actually it’s ready for testing. sorry for not making that clear in my previous message.

I tested with 0.30.1. Here’s the discovery logs. Pastebin ending in X3d7vkp2
Nothing changed in behaviour; nothing happens when I short/long press a button.