Sonoff ZBDongle-E

Is the Sonoff Zigbee 3.0 Dongle Plus (E-Dongle) supposed to work with Nymea?
This is now the second copy of that type I tried to connect to Nymea. Nymea correctly recognizes the type, reports invalid headers and ends with failure.
I use the dongle as it comes out of the box. In the internet I find many references that tell of the dongle needing to be re-flashed. Is that relevant for this case?

Uh. We had the same discussion today in the telegram group. Turns out the v2 is using an entirely different chipset and is not working with nymea. Only the V1 is.

We’ve already updated the docs on the staging server and will deploy that to the production website soon

Currently there’s no estimate on having this one supported.

1 Like

Hello there. I also have the same problem I discovered. What I plan to do is this, even though it’s not a perfect world:

  • buy a Dongle-P (the one that works with Nymea)
  • try to flash the Dongle-E as a range extender / router and use that underneath the Dongle-P - rather than returning the device
  • try to help test and maybe even help porting it over to Nymea so that it works as a controller as well later.

If you want to DM me perhaps we can explore some unique paths together to make more lemonade than lemons from our situation?


Oh well. It’s just a toy, and it doesn’t seem to work with HA, either. I think I might reflash it, too, and use it as a range extender. My home extends over three floors and the coverage is a bit spotty.

Unfortunately, writing software for that kind of thing is quite beyond me.

Would it not be sensible to explicitly name the dongle as the E type? It is marketed by that name.

I propose writing the warning to include something like this:

Caution: The following device is not supported yet and looks identical to Version 1 other than the customer-facing model number:

USB EEPROM Product Description ID: SONOFF Zigbee 3.0 USB Dongle Plus V2
CHIP: Silicon Labs EFR32MG21
Customer-facing model number: Dongle-E

1 Like

I tried again to us the Dongle-E with Home Assistant and with openHAB. There are explicit step-by-step instructions on Sonoff’s web site. Neither system succeeds in communicating with the Dongle-E.
iobroker, on the other hand, was immediately able to access and use the Dongle-E.