[solved] Registering to cloud fails

Hey there.
I am having the same problems as here:

However, that solution (deleting cloud section and line with uuid in nymead.conf) does not seem to work.

I had to restore a dd image on the SD card after playing around a bit, which broke my cloud connection. I also tried registering my pi zero after putting a brand new nymea image on it (account is the same as before).

Thanks for any suggestions.

Try generating a new uuid for /etc/machine-id ( watch out for correct formatting) in addition to removing the config entries.


I forgot to restore all the directories necessary i.e: /etc/nymea & /var/lib/nymea

After I restored all the directories inside these two everything was ok.

1 Like

Thanks, this solved my issue.
So in essence:

  • remove [cloud] section and machine uuid from nymead.conf
    sudo vim /etc/nymea/nymead.conf
  • then sudo rm /etc/machine-id
  • then sudo systemd-machine-id-setup



Thx @mzanetti and @itarill!

This solved it for me too.

All the best!