Reboot Nymea:core Issue

I have mentioned this a long time ago and nothing has been done to fix it. Under General Settings-system there are 2 options. One is labeled “Reboot NYMEA:CORE” and the other is labeled “Shutdown Nymea:CORE”. They are actually functions that reboot the entire server which NYMEA should not do! These should only affect NYMEA core and not reboot my entire server which affects other applications on my server. Please fix this so it only deals with the NYMEA:CORE application and not the entire server.

Hmm… So, we won’t remove that option to reboot the entire machine… One of the main use cases of nymea is that it runs on a dedicated embedded device (e.g. a raspberry pi) and rebooting the entire machine is very much wanted. However, I can see how this might not be a preferable option on a setup where nymea runs on a host sharing the system with other services. I could add a restart nymea only option too there…

Also you can uninstall nymea-system-plugin-systemd to get rid of those buttons altogether if you want to prevent yourself from accidentally pressing it.

My issue is not that I might accidentally hit the wrong button but rather my other users hitting the wrong buttons. As I have failed to find a method to have different user access levels so that only certain users have access to critical setup functions I define, I do request that at least the buttons at an absolute minimum be labeled correctly which these are definitely not labeled correctly. What I would really desire is that I have a user level controls that I can prevent (or allow) access to certain setup configurations capabilities based on the user (hope that clear). If you have this already, where is the docs so I can figure out how to set it up?

Right… Yeah, more fine grained permission management isn’t there yet. But certainly on the roadmap. Can’t make any promises on the timeline tho as it’s quite a bit of a task.

So yeah, for now I’d probably recommend to sudo apt-get remove nymea-system-plugin-systemd to disable the reboot/shutdown feature altogether. That should get rid of this problem for you then.

Not sure why you think they’re labelled wrong… “Reboot” kinda means power cycling the machine to me, especially if it’s next to a “Shutdown” button.

Anyhow, I’ve just added support for restarting, perhaps that makes it more clear if there are “Restart”, “Reboot” and “Shutdown” options…



Ok, I will give you my suggestions. “Reboot NMYMEA” and “Reboot SERVER”

Your current label reboots the server and not the application.
Ok, rebooting the server restarts everything but it is missleading.

Saying “Restart NYMEA” when you restart the server has exactly the same issue to me (i.e. using restart vs reboot) .

that is what I meant!
PS this is delayed because I responded to the email which never got delivered. Oh well.