PlatformZeroConf warnings

Hello,

Recently, my nymea’s logs are periodically filled with the following warnings:

W | PlatformZeroConf: Could not register service “nymea-http-insecure” 80 “_http._tcp” . The client is not available.
W | PlatformZeroConf: Could not register service “nymea-mqtt-default” 1883 “_mqtt._tcp” . The client is not available.
W | PlatformZeroConf: Could not register service “nymea-ws-default” 4444 “_ws._tcp” . The client is not available.
W | PlatformZeroConf: Could not register service “nymea-http-secure” 443 “_http._tcp” . The client is not available.
W | PlatformZeroConf: Could not register service “nymea-tcp-default” 2222 “_jsonrpc._tcp” . The client is not available.

What’s the problem and how can be solved.

This looks like avahi is not running perhaps…

How did you install nymea?

The installation was good because those warnings appeared days after installation. Maybe I should try a reboot of nymea.
What clients those warning refer to?

It’s the avahi-client… nymea connects to avahi to register and browse mDNS/ZeroConf. Apparently that client is not available. Most likely this is caused by avahi not running.

You can check with systemctl status avahi-daemon if it’s running…

Yeah, perhaps check if a restart fixes this.

Everything is fine now, after restarting the nymea:core.
Thank you :pray: