New RPi image available for testing

Hey folks!

There’s been a lot of good feedback on the Hackster article with the RPi Touchscreen setup (

As this project had been received that well, I decided to put some more efforts into it and I’m happy to announce a first test release for it.

Here’s the brand new Raspberry Pi image for nymea. But it doesn’t only support nymea as the previous RPi images, but it comes with nymea:app in kiosk mode, preinstalled and ready to go out of the box.

Nymea:app also received a bunch of updates for this to happen. Check out the new “Network setup” and “System update” sections in Box settings. Thanks to those, ideally you would not need to touch the command line on your Raspberry Pi any more at all. Everything can be done from the UI.

Note, this image contains tech preview stuff atm. That, is, it follows our “landing-silo” aka “testing” track. When all the requirements have made it into the stable release I plan to release this image as the new official nymea image. So take the chance to try it out and give me feedback!

There is one known issue so far: At the very first boot the app seems to be struggling to connect to the nymea:core. I’ll look into that before the final release. If you happen to run into that, reboot it once more and it should work.

Enough yadda yadda, get me the image, right? Heh, here it is:

It should work on all Raspberry Pi models 2 and 3. That is, also the Raspberry Pi 3B+.

Have fun and don’t forget to provide feedback how it went!

1 Like

It is awesome!

nymea:app didn’t connect to nymea:core (tried 3 reboots just to be sure).

Thus I set the system up with a nymea:app on my iPhone (user + password).
After the setup and a reboot I could log in the local nymea:app instance with the same credentials, since then it is properly tied together.

This works fluent, I’m impressed. :slight_smile:

Hmm… strange it wouldn’t connect at all… Yeah, I’ll definitely have to look into the bootup sequence. I did see it fail too occationally. I wonder if it’s reproducible for you… If so I’d appreciate some logs of your setup, given that mine always seems to only fail on the very first attemt - if at all.

Glad you like it :slight_smile:

New prerelease image uploaded at:

It should have all the things fixed Simon reported here (and some more).

Worked like a charm for me! :slight_smile:

The only thing: In the setup process, the password cannot turned into visible.
This would be very helpful.

Thanks for the feedback. Will add that.

Hi all, and Hi Michael. I just flashed the last version of the image. Works as a charm. Great work, I’m very happy for it.

I was wondering, If I can connect devices built by me, that are using wifi or bluetooth?

Hello Kerekes,

Yes, it sure should be possible to create plugins for self built hardware.

This is probably where you want to start:
Also, for Bluetooth related hardware, this is hopefully a nice tutorial:

Have a look at all the other open source plugins too, which are located at:

Either the password requirements are ridiculously strict, or there is a bug when doing initial setup. No matter what I enter into the password fields it rejects it and says it’s too simple. Using pre5.

Edit: After a reboot it accepted a password with 17 characters including caps, numbers, and symbols. One that it didn’t accept the first round though, might still be a bug.

I assume you’ve used “nymea:app” as client. The app states the password rules:

The password needs to be at least 8 characters long, contain lowercase, uppercase letters as well as numbers and special characters.

Once you logged in, you can change nymea to not require a login in “nymea:app > System settings > API interfaces”

Hi Yogsothog,

welcome to the forum! Thanks for the feedback. Indeed, the requirements are a bit strict in a sense that they require special chars, upper- and lowercase letters as well as numbers… However, the minimum length is 8.

Looking at the code, one issue I could image might be that a special character you used is not recognized as special character and it still asks you to add another special character. Could that be the case?

This is the code that does the check:

bool UserManager::validatePassword(const QString &password) const
    if (password.length() < 8) {
        return false;
    if (!password.contains(QRegExp("[a-z]"))) {
        return false;
    if (!password.contains(QRegExp("[0-9]"))) {
        return false;
    if (!password.contains(QRegExp("[!\"§$%&/()#*\\'+\\.\\\\@€µ~]"))) {
        return false;
    return true;

Anything comes when running your password thought this?

I figured it out, rebooted and it accepted a password, I should have tried that before posting. Now I can’t get it to find my Wemo switches and outlets. I have everything on the same network but the Nymea:app on both the Pi and my phone can’t find them.

There has been a bug in the wemo plugin which would prevent it from being discovered if the device has been renamved to something else than “WeMo Switch”.

This bug has been fixed in version 0.12.3 of the nymea-plugins package. Which version do you have?

You can check the installed version in System Settings -> System updates -> Add/remove software.

Try to update. If that doesn’t fix it, I’d probably need logs to find out what’s going on.

I swear this system is trying to make a fool out of me. When I checked the last 5 times there were no updates, now there are 42 including Wemo. I am running the updates now (one by one because of course it fails if I try all at once), hopefully this will fix it. I think my RPi has a very lively and mischievous little machine spirit residing in it.

Hmmm… Odd, it shouldn’t fail doing all at once… It would be helpful to see the logs. You can find that in the debug interface, in system settings -> developer tools, then the download tab and download the system log.

Here is the log.

Ok, so it turned out to be not the best idea to build the RaspberryPi image based on Ubuntu. Upgrading them is virtually impossible, unless you are an expert on apt-get.

For this reason, and also because the Ubuntu kernels for the Raspberry Pi don’t support the RPi4 yet, we switched back to using Raspbian as base for our images.

Sorry for that, the new image is now hosted at and should prove more stable in the long run.

Existing installations of the Ubuntu image will continue to work and also receive updates for a while, however, keep in mind that especially updating them is a bit of an issue.

1 Like