Installing older nymea version

Hi,

I want to install a older version of nymea (0.30.0). apt-get install nymea=0.30.0+202112110029~buster+rpi1. It does not work due to dependencies.

I get following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nymea : Depends: nymead (= 0.30.0+202112110029~buster+rpi1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Is it possible to install a older version?

You’d probably need to explicitly list all the packages and the according 0.30 version

With this commands I have installed the Version 0.30.0:

It is important to keep the order


sudo apt-get install -y dnsutils 
sudo apt-get install -y iputils-tracepath
sudo apt-get install -y libirs161
sudo apt-get install -y libqt5bluetooth5=5.12.5-1+rpi1
sudo apt-get install -y libqt5bluetooth5-bin=5.12.5-1+rpi1
sudo apt-get install -y libqt5serialbus5=5.12.5-1+rpi1
sudo apt-get install -y libqt5serialport5=5.12.5-1+rpi1
sudo apt-get install -y libqt5sql5=5.12.5+dfsg-2+rpi1
sudo apt-get install -y libqt5sql5-sqlite=5.12.5+dfsg-2+rpi1
sudo apt-get install -y libqt5websockets5=5.12.5-2+rpi1
sudo apt-get install -y libqt5xml5=5.12.5+dfsg-2+rpi1
sudo apt-get install -y libnymea-gpio=1.0.5+202112110029~buster+rpi1
sudo apt-get install -y libnymea-mqtt=0.1.9+202105191824~buster+rpi1
sudo apt-get install -y libnymea-networkmanager=0.5.2+202112110029~buster+rpi1
sudo apt-get install -y libnymea-remoteproxyclient=0.1.14+202105191824~buster+rpi1
sudo apt-get install -y libnymea-zigbee1=0.1.4+202112110029~buster+rpi1
sudo apt-get install -y libnymea1=0.30.0+202112110029~buster+rpi1
sudo apt-get install -y nymea-cli=1.1.7+202106302323~buster+rpi1
sudo apt-get install -y nymea-apikeysprovider-plugin-community=0.6+202106302323~buster+rpi1
sudo apt-get install -y nymea-system-plugin-systemd=0.9+202105191824~buster+rpi1
sudo apt-get install -y nymea-zeroconf-plugin-avahi=0.12+202110041537~buster+rpi1
sudo apt-get --no-install-recommends install -y nymea-translations=0.30.0+202112110029~buster+rpi1 
sudo apt-get --no-install-recommends install -y nymea-data=0.30.0+202112110029~buster+rpi1
sudo apt-get --no-install-recommends install -y nymead=0.30.0+202112110029~buster+rpi1

FWIW, you can also give multiple packages (with version) in a single apt-get call.

That said, I am wondering why you’re doing this in the first place. Is something not working in newer versions?