Inconsistent taxonomy for ZigBee devices

I rebuilt my system from scratch: removed all devices from ZigBee network, reset the ZigBee controller (ConBee II), restarted nymea:core with a freshly downloaded image for the Raspberry Pi.

Surprise one: many of the devices I had manually removed from the ZigBee net reattached themselves as soon as the network was up again and open for new devices. In some cases, this was not so useful as I could not tell one sensor from the other, so I did not know which sensor was in which room. I should have noted the device ids before shutting down the system.

Surprise two, and this is the issue of this thread: I now see two devices which used to be tagged as routers which are now shown as end devices.

One is a philips power plug (phMusik). I just added another plug of the same make and it’s shown as a router.

The other is a GLEDOPTO LED strip. It, too, used to be shown as a router and now it’s not.

In the former incarnation of my system, in the network map the devices were correctly shown. Now, they appear as end devices and I have some end devices for which there is no path to nymea shown even when they’re connected and active.

This is the network map:

or this, with another node selected

Hi @pop
Did you factory reset your devices before your surprise one? I also noticed that some devices just rejoin, if you use the same channel on the new network. You could try another channel then, if that is possible in your case.
Your surprise two I noticed in rare cases as well, but with a factory reset and new joining of the device it reported in again normal.

Hi,
No, I did not factory reset the devices.
In any event, I think Nymea should consistently report a device either as an end device or as a node. The fact that the same kind of device is treated inconsistently seems to point to an error in the software.

Indeed it seems wrong that those devices are recognized as end devices… Is this reproducible when you remove and re-add it? If so, mind posting the logs of the node inspection process? For that, enable the Zigbee debug logs in the debug web interface and then paste the node descriptor which is printed during inclusion.