IC2 - DS18B20 - temperature sensors

Hi there!

I tried to add two temperature sensors via the one-wire plugin.

Unfortunately I am not able to add the IC2 interface with the parameters --i2c=ALL:ALL

Do I need to specify something else?

Both the sensors are recognized by the system because I have two directories in the /sys/bus/w1/devices directory with the right temperature.

Hope someone has a solution, because I need the sensors to make decisions based on it for my Koi pond.

Regards,

André

I must admit that I haven’t done anything with the one wire stuff yet, even tho I do have a bunch of such temperature sensors here. Maybe @bernhard.trinnes has some hints as he’s the author of the one-wire plugin. Otherwise I’ll see if I can get mine going and report back within the next days.

1 Like

The One wire plugin uses i2c, so I need to connect the 18B20 sensors to an i2c board instead of directly connect the 1 wire to the GPIO4 port.

Will get me one board and play around with that. Maybe some extra documentation clarifies it better.

Regards,

André

Hi Foenky,

it seems you have the one wire kernel module enabled.
The init argument --i2c=ALL:ALL tells owfs to look for 1-wire bus master
devices on each i2c interface.

In your case the init argument “–w1” should be all you need, so owfs takes the kernel module instead (not yet tested).

Bernhard

1 Like

Hi Bernhard,

And now the parameter is tested :wink:

All the sensors are there and working.

Thanks a lot!

André

2 Likes

Hello Foenky and Bernhard,

I’ve followed the instructions in this thread and added the one wire plugin and set the init
argument to “–w1” and toggled the auto add one wire devices to on (green). the “connected” line displays a green dot however I am getting the “Too bad… no things found” error when trying to add a DS18B20 temp sensor. I’ve got the sensor set up correctly and can read it’s output in Raspberry OS. I’ve tried adding the sensor manually with the auto add toggled on and off and waited for the system to find the sensor on it’s own via auto add.

Any suggestions you might have would be appreciated.

Hi,

please note that the correct argument is --w1, not as previous posted “–w1” which was auto-corrected.

Bernhard

Hello Bernhard,

Thank you for the quick reply. I entered the arguement correctly as --w1 without success.

I then started the debugging interface going and it is giving me the following error.

W | WebServer: User-Agent header is missing
W | OneWire: ERROR initialising one wire Invalid argument
W | ThingManager: Thing setup failed. Not adding thing to system.
W | WebServer: User-Agent header is missing
W | PlatformUpdate: Connection to PackageKit lost
W | WebServer: User-Agent header is missing

hopefully that is something that makes sense to you.

Karren

Hmm… seems like you still made a mistake with the argument…

I’ve reported this bug to the OneWire plugin:

I’ll simplify the setup process, but that will take time. Like @mzanetti pointed out it seems there is still something wrong with the given argument.

See this page for all the possible OWFS arguments:
https://manpages.debian.org/testing/owfs-fuse/owfs.1.en.html

Bernhard

I started working on the direct W1 kernel support. In the near future you will not be required to setup an OWFS interface anymore.

1 Like