Hue Bridge wrong ip

I wanted to connect my hue Bridge (which is in dead a phoscon raspbee).
but nymea finds two bridges with different ip addresses. And both are wrong and in the wrong subnet. My internal ip is 192.168.0.x

Right… The issue here is that Hue offers a thing called “N-UPnP” for discovery. Hue bridges register themselves at with their public internet IP address and clients can search for them by comparing their own public internet IP.

While this works fine in most of the cases, this causes such issues in combination with some ISPs. For instance Unimedia (now Vodafone) in Germany which offer IPv6-only internet connections and then use a 6-to-4 NAT for a group of many customers to route them from their IPv6-only connection into the IPv4 internet. As they will all share the same public IPv4, the Hue servers think they’re all in the same LAN.

Now while that explains why you see wrong entries, it doesn’t yet explain why it doesn’t find the right one too.

What do you mean by saying it is a phoscon raspbee? Does that mean that you’re not using an actual Hue Bridge but instead have connected your Hue Lights to a self-built ZigBee gateway?

Last one is right.
I have a raspberry pi as a ZigBee gateway that emulates a Hue Bridge.
It is done with a and a software called DeConz.

In OpenHAB i can access DeConz directly or via Hub Bridge.

I think it would help if i can configure the ip address manually.

Hmm… I know that we had the option to add the Hue Bridge manually… The problem with fixed IPs is that they stop working when the DHCP lease time expires and most users don’t assign static IPs to their Hue bridge. Because of this that option has been removed and the plugin now always auto-discovers the Bridge…

One thing you could do, is to announce your RPi like a real hue bridge would do by running something like this on the RPi that fakes the Bridge:

avahi-publish-service -s FakeHue _hue._tcp 80 bridgeid=ecb5fafffe035cc7

I’ve just tried it and nymea finds it this way. If the IP of your Raspberry Pi changes, just re-run the command and nymea will update its Hue Bridge configuration on the fly.

However, you might be interested to know that in our experimental repository we have added support for the Conbee (also RaspBee) hardware. The current plan is to release it with 0.25.
If you enable the experimental repository, you’ll find a new plugin named “nymea-plugin-zigbee”. Installing that, you can add the RaspBee directly in nymea and then connect your hue lights directly to nymea without the need of the hue bridge emulation, or DeConz or anything. Just nymea taking direct control over your ZigBee network.
Please note that experimental is named experimental for a reason tho. Also I might add that this doesn’t yet support all the things that DeConz offers (and it will probably be quite a bit until we do).

So if you intend to only use nymea as your main controller, using nymeas ZigBee plugin is probably way to go as you won’t need to maintain a DeConz instalation any more and can do smart rules with nymea. However, if you plan on using OpenHAB alongside with nymea or want to use the Hue Bridge emulation for other tools too, you probably want to go with the discovery hack.

Please be so kind and let me know if it worked. Thanks :blush:

The avahi worked very nice.
Now i see all things from the zigbee network in nymea.

However, i want to replace openhab with nymea. So in the future i will install the zigbee plugin.