Font size in script editor

Hi all! I have very basic question about font size in nymea script editor - there is any way to increase the size? Despite different DPI, computers etc. it’s painfully small and causes eye strain.

You can press Ctrl+ +/- to zoom in/out like in a browser

1 Like

I have never thought that it would be so simple, thanks! However, it works ok with +/- on numpad, but on number row ctrl + “-” doesn’t not work in my case

Hmm, seems strange that there’s a difference, as the app can’t even distinguish between the two (the operating system sends the same keycode normally). I can’t reproduce it here but I only have a laptop keyboard. Perhaps the window wasn’t focused properly when you tried it? It only works if the text editor has the active focus.

If you’re able to compile the app yourself you could enable this debug print and see what keycode exactly is coming in from both keys.

I have tried both (I have laptop with numpad), window focused, with numpad works like a charm, with
number row only ctrl+shift+ (=/+) works for zooming :confused: For now I don’t know how to compile the app, for curiosity I checked this site: JavaScript Key Code Event Tool | Toptal® - I don’t know if it is relevant for this case, but in my case ctrl + “-” on row number has 189 keycode, ctrl + “-” from numpad: 109

It’s probably sending a dash or hyphen then… JS keycode 189 seems to be “dash” but in the QT keycode list there is no dash but a “hyphen”. Could try to add that…