Cant disable screen saver

One on of my setups, after some updates, the screen blacks out after a few seconds of no activity. I have the setting in app settings to black screen NOT SET. It stayed on previously, so weird.

What controls the the blanking of the screen?

–John

Hi. The blanking of the screen is controlled by the app itself. However, depending on what else you’ve installed there could potentially be something else that does it. I’ve just tested it and it seems to work fine here which indicates it’s probably not a bug in the apps code but rather something in your setup.

Are you using the “old” X11 based installation or did you move to the Wayland based one?

Good question, how can I tell?

If you’ve installed this image after 0.27 was released (or using an experimental image from the time before 0.27) then it’ll be on Wayland, else X11 still.

I can confirm the issue started on the last update run i did. I know this because both office and RV did not have the issue, after i ran updates they did.

I see this process running, so im assuming its X11.
nymea@RVnymea:~ $ ps aux | grep X
root 462 0.4 4.7 122844 44656 tty7 Ssl+ 15:03 0:02 /usr/lib/xorg/Xorg -s 0 -dpms :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

I can confirm screenblank is set to “0”:
cat /sys/module/kernel/parameters/consoleblank
0

Any idea what is running causing the blanking?

I’ve installed an old image and then upgraded it. Still works fine for me…

So, the files used are:

/sys/class/backlight/rpi_backlight/bl_power
/sys/class/backlight/rpi_backlight/brightness

Try writing some values manually to them to see if it’s working… Then maybe check the permissions on those files… the package nymea-app-kiosk-x11 should install a file to /lib/udev/rules.d/90-pi-backlight.rules that enables nymea-app to write to this file…

Also check the app logs for error… directly at app start it should print some information about the backlight control. Maybe enable PlatformIntegration logs in app settings → developer options.

Getting somewhere, when i echo a “0” to the bl_power the screen comes on. If we play with the screen and bit and do stuff, it sets it back to 1. Heres what my files look like:

nymea@nymea:~ $ echo 0 > /sys/class/backlight/rpi_backlight/bl_power
nymea@nymea:~ $ cat /sys/class/backlight/rpi_backlight/bl_power
0
nymea@nymea:~ $ cat /lib/udev/rules.d/90-pi-backlight.rules
ACTION==“add”, SUBSYSTEM==“backlight”, RUN+="/bin/chgrp nymea /sys/class/backlight/%k/bl_power"
ACTION==“add”, SUBSYSTEM==“backlight”, RUN+="/bin/chmod g+w /sys/class/backlight/%k/bl_power"
ACTION==“add”, SUBSYSTEM==“backlight”, RUN+="/bin/chgrp nymea /sys/class/backlight/%k/brightness"
ACTION==“add”, SUBSYSTEM==“backlight”, RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"
nymea@nymea:~ $ ls -l /sys/class/backlight/rpi_backlight/bl_power
-rw-rw-r-- 1 root nymea 4096 May 18 11:04 /sys/class/backlight/rpi_backlight/bl_power
nymea@nymea:~ $ ls -l /lib/udev/rules.d/90-pi-backlight.rules
-rw-r–r-- 1 root root 384 Mar 19 07:40 /lib/udev/rules.d/90-pi-backlight.rules
nymea@nymea:~ $

So the screen keeps going off even while you’re interacting with it?

Well, yea…after you stop interacting.

So setting the value in the file to “0” sets it to on, and it will stay on. Once you play with the touch screen and do somthing, it seems to reset it to auto black…so after your done doing somthing a few seconds later it blanks.

–John

OK… I just tried again here in my X11 based setup. Sadly I still can’t reproduce the issue. Please go to App Settings → Developer options → Configure logging categories and enable full debug for “PlatformIntegration”.
Then enable/disable the screensaver option and check the logs. It should print “Setting screen timeout to -1 ms”. Can you confirm that?

Right after I had sent the previous message my screen went off even though it shouldn’t have. So I’ve checked the log and code and indeed found an issue. It’s not clear to me yet how it did not reproduce in the first place but anyhow, should be fixed in the next experimental build and will be released to stable with 0.27.1 (Yes, we’ll be having a .1 bugfix release this time - soon).

Thanks for the report and the patience.

Perfect, at least i know im not crazy here!

–John

seems to be working fine now with todays experimental update

Yep, worked perfect. After a few weeks still solid!

–John