Can i force BerryLan to use wlan0?

I am setting this us as an access point with a second wifi dongle, and need to only change connectivity with BerryLan on wlan0 (wlan1 will be the access point). This is how the access point is configured:

apt-get install hostapd dnsmasq -y

systemctl stop hostapd
systemctl stop dnsmasq

sed -i -e ‘s/#DAEMON_CONF=""/DAEMON_CONF="/etc/hostapd/hostapd.conf"/g’ /etc/default/hostapd

echo “interface=wlan1
driver=nl80211
ssid=myssid
hw_mode=g
channel=10
country_code=US
wmm_enabled=1
auth_algs=1
ignore_broadcast_ssid=1
wpa=3
wpa_passphrase=mypasswrd
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP” > /etc/hostapd/hostapd.conf

echo “interface=wlan1 # Use the require wireless interface - usually wlan0
dhcp-range=192.168.4.2,192.168.4.20,255.255.255.0,24h” >> /etc/dnsmasq.conf

echo “interface wlan1
static ip_address=192.168.4.1/24
nohook wpa_supplicant” >> /etc/dhcpcd.conf

systemctl unmask hostapd
systemctl enable hostapd
systemctl enable dnsmasq

this works great to create the access point, but after installing BerryLan, this becomes the configuration

3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 86:3a:8c:##:##:## brd ff:ff:ff:ff:ff:ff
4: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 1c:bf:ce:##:##:## brd ff:ff:ff:ff:ff:ff
inet 10.0.0.8/24 brd 10.0.0.255 scope global dynamic noprefixroute wlan1
valid_lft 86337sec preferred_lft 86337sec
inet 192.168.4.1/24 brd 192.168.4.255 scope global noprefixroute wlan1
valid_lft forever preferred_lft forever
inet6 fe80::afdf:534d:941f:b29c/64 scope link noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::5a4c:e6df:8b7f:6a1/64 scope link noprefixroute
valid_lft forever preferred_lft forever

any advice on how to get BerryLan to use wlan0 instead of wlan1?

Hi @Beandip408,

I have just checked the code. Apparently right now nymea-networkmanager will use the first wifi device it can find and there is no config to change that at this point.

If you can change the code and rebuild it yourself, you could create a build that takes another device wifi device. The code in question is here:

You might also report a feature request on github for us to improve the situation in upcoming releases.