App dont Work with new Release 0.31.1

Hello,

I have updated my nymea to 0.30.1+202201201702~buster+rpi. But now I get an error message while I’m starting the app:


I installed the latest app.

Is possible that the is compiled with QT6?

Best regards
Michael

Hi,

indeed, the stable app currently can’t connect to the experimental version of the core. However, there should be working beta versions of the app available on all platforms.

As for the compiling, Qt6 isn’t fully enabled yet. There is a branch named “qt6” in the app repository which would allow you to build and run it but there is stuff just commented out so it will be buggy in some areas. The current officially supported qt version are from Qt 5.9 up to 5.15.2. But again, unless you want to work on the code, you shouldn’t need to build it yourself, just install the beta version of the app.

Thanks
I downgraded to 0.30 and everything works fine.
I had in my /etc/apt/sources.list.d/nymea.list the experimental repo and the systemupdate installed the 0.30.1. I had not thought about that anymore.