Adding One Wire interface to RPi

Hi all, complete newbie looking for help

Setting up a headless install of Nymea to replace a faulty hot tub control board. I’ve wired in my DS18B20 temp sensor, but can’t add the One Wire gateway, I just get an error and the option to try again. I’ve checked it’s installed and showing on the list of installed plugins, but still nothing.

If I got and try to add in a One Wire temp sensor, i get an error that I need to add in the gateway, so back to square 1…

I’m using the default argument and tried everything suggested in the other threads, but can’t seem to find the magic to get it working…

Thanks in advance!

Hi, does this help? onewire · documentation

If not, perhaps check the logs for errors (system settings → developer tools - > debug interface → logs tab)


I read through the documentation, but it wasn’t too clear to me.

I’ve downloaded and tried to add the one ware gateway, and that’s where it stops. By default the argument has “—i2c=ALL:ALL” section included, but it still just gives me an error.

Do I also have to install the W1 kernel driver? If so, how do I do this using the app, as the system is running in headless mode?

Which error is it?

Hmm, according to the docs you’d need to at least enable one wire in raspi-config, yes. Use ssh to log in.(putty if you’re on windows). User nymea, password nymea


Went into the config and enabled the One Wire interface using raspi-config. Still get an error when trying to add the One Wire gateway, but if I try add a temperature sensor, it now finds it and seems to read correctly.

Is there a simple way to add a temp set dialogue on the app to a relay controlled heating unit? I would like to be able to set the temperature using the app as the user interface, and then have the temp probe tuning on a relay to control the heater

Have used magic to set an upper limit that turns the heater off, but hoping that there’s a better way than setting multiple preset temperatures via the magic menu. I’ve added a generic heather from things

Thanks for the help so far!

You may want to try the generic thermostat and use the IO connection in the thing settings

Thanks Michael

Will give that a try!

Next step is to work out why my physical buttons aren’t working, but my virtual buttons are…